US07 - Intermittent Degraded Performance
Incident Report for MWRMM
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 08:36 EDT
Investigating
We are currently experiencing intermittent performance issues within Barracuda RMM. Until this is resolved, partners may experience disruptions while the issue is being investigated.

We will provide an update and/or resolution when more information is available.

Kind regards,
Your Barracuda RMM Team
Posted Mar 14, 2024 - 11:52 EDT
This incident affected: US07 UI and Data Web Pages (US07 UI).