Degraded Performance - Onsite Manager and Device Manager Downloads
Incident Report for MWRMM
Resolved
The issue preventing Onsite Manager and Device Manager downloads has been resolved.

If still facing issues please reach out to Barracuda RMM support
Posted Mar 08, 2024 - 10:10 EST
Investigating
We are currently experiencing performance issues within Barracuda RMM. Until this is resolved, partners may not be able to download Onsite Manager and Device Manager packages

We will provide an update and/or resolution when more information is available.

Kind regards,
Your Barracuda RMM Team
Posted Mar 08, 2024 - 08:31 EST
This incident affected: US01 UI and Data Web Pages (US01 Data), AU01 UI and Data Web Pages (AU01 Data), EU01 UI and Data Web Pages (EU01 Data), US03 UI and Data Web Pages (US03 Data), US04 UI and Data Web Pages (US04 Data), US05 UI and Data Web Pages (US05 Data), EU02 UI and Data Web Pages (EU02 Data), US07 UI and Data Web Pages (US07 Data), and EU03 UI and Data Web Pages (EU03 Data).