Partners are not receiving emails from Barracuda RMM

Incident Report for MWRMM

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 08:48 EST

Investigating

The Barracuda RMM Support Team has become aware of an issue affecting emails from Barracuda RMM that are not being received. Our Operations Team is currently investigating how to repair the problem.
Posted Jan 05, 2026 - 09:18 EST
This incident affected: US01 UI and Data Web Pages (US01 Data), AU01 UI and Data Web Pages (AU01 Data), EU01 UI and Data Web Pages (EU01 Data), US03 UI and Data Web Pages (US03 Data), US04 UI and Data Web Pages (US04 Data), US05 UI and Data Web Pages (US05 Data), EU02 UI and Data Web Pages (EU02 Data), US07 UI and Data Web Pages (US07 Data), and EU03 UI and Data Web Pages (EU03 Data).